Advisories · Weakness
CWE-436.
Every Advisory and CVE whose sources give the weakness CWE-436, newest first.
- CVSS 8.2 High
http-cache-semantics through 4.2.0 Cross-Client Cache Disclosure via Vary Wildcard
- kornelski http-cache-semantics
- CWE-436
- CVSS 7.5 High
LMDeploy has an SSRF bypass
- Server-side request forgery (SSRF)
- CWE-436
>=0.12.3, <0.15.0 · fixed in 0.15.0
GHSA-39wr-7q6h-cf68 - CVSS 2.4 Low
OpenClaw ClawScan File Classifier static_scanner.go IsBinaryFile interpretation conflict
- OpenClaw ClawScan
- CWE-436
- CVSS 7.0 High
Traefik entrypoint header-name sanitization bypassed via request trailers
- CWE-436
- CWE-807
>=3.2.0, <3.7.13 · fixed in 3.7.13
GHSA-v67p-phpq-fc8x · CVE-2026-88004 - CVSS 6.5 Medium
Google Chrome: Interpretation conflict in Safebrowsing in Google Chrome on on Mac prior to 153.0.8010.36…
- Google Chrome
- CWE-436
- CVSS 8.3 High
Nodemailer: IDN/Punycode domain allow-list bypass leads to email delivery to an attacker-controlled domain
- CWE-20
- CWE-436
<9.1.0 · fixed in 9.1.0
GHSA-wmmp-3585-3rmp · CVE-2026-92598 - CVSS 8.3 High
Nodemailer: Recipient-domain validation bypass via RFC 5322 comment mis-parsing leads to email delivery to an attacker-controlled domain
- CWE-20
- CWE-436
>=6.9.16, <9.1.0 · fixed in 9.1.0
GHSA-cc9r-2j5m-2m83 · CVE-2026-92597 - CVSS 7.7 High
Roo-Code 3.54.0 Auto-Approve Bypass via Shell Parser Word-Boundary Mismatch
- RooCodeInc Roo-Code
- CWE-436
- CVSS 8.2 High
Visual Studio Code Security Feature Bypass Vulnerability
- Microsoft Visual Studio Code
- CWE-436
- CVSS 9.1 CriticalCritical · CVSS 9+
@fastify/middie vulnerable to path-scoped middleware bypass via absolute-form request target
- @fastify/middie
- CWE-436
- CVSS 6.5 Medium
CKAN MCP Server: Cache-key canonicalization collision enables cache confusion / poisoning
- CWE-345
- CWE-436
<0.4.112 · fixed in 0.4.112
GHSA-78x9-fhhx-v2g6 · CVE-2026-73846 - CVSS 5.3 Medium
Mail: Email address spoofing via malformed RFC 2047 encoded-words
- CWE-436
<2.9.1 · fixed in 2.9.1
GHSA-mvxr-6m87-mv2q · CVE-2026-63435 - CVSS 7.5 High
fast-uri vulnerable to host confusion via skipped IDN canonicalization on scheme-relative references
- CWE-436
>=2.4.2, <2.4.5 || >=3.1.3, <3.1.6 || >=4.0.1, <4.1.3 · fixed in 2.4.5, 3.1.6, 4.1.3
GHSA-5jgf-p345-68v8 · CVE-2026-75931 - CVSS 9.4 CriticalCritical · CVSS 9+
authentik: Account Takeover via SAML NameID Comment Truncation
- authentik
- CWE-436
- CVSS 6.0 Medium
stringprep.map_table_b2() deviates from RFC 3454 Table B.2
- Python Software Foundation CPython
- CWE-436
- CVSS 8.7 High
Network-AI SandboxPolicy before 5.15.1 Blocklist Bypass via Quote Mismatch
- Jovancoding Network-AI
- CWE-436
- CVSS 8.7 High
Network-AI ClaudeHookBridge Deny Pattern Bypass via Truncation
- Jovancoding Network-AI
- CWE-436
- CVSS 3.0 Low
IBM i is Affected By security restrictions bypass in Navigator for i
- i
- CWE-436
- CVSS 7.5 High
Apache Airflow's Backfill API authorized a request against a Dag id supplied by the caller whenever the `backfill_id` path segment failed to parse. The authorization dependency parsed it with `int(...
- CWE-436
<3.3.1 · fixed in 3.3.1
GHSA-j4jc-cq9h-xrhr · CVE-2026-68968 - CVSS 7.5 High
@fastify/static vulnerable to route guard bypass via non-canonical path segments
- @fastify/static
- Path traversal
- CWE-436
- CVSS 7.2 High
Guzzle: Noncanonical host can bypass host-based checks
- Server-side request forgery (SSRF)
- CWE-180
<7.15.2 || >=8.0.0, <8.0.1 · fixed in 7.15.2, 8.0.1
GHSA-v5mv-p594-2x33 · CVE-2026-69246 - CVSS 5.9 Medium
undici vulnerable to cross-user information disclosure via whitespace around equals in Cache-Control directives
- CWE-436
- CWE-524
>=7.0.0, <7.29.0 || >=8.0.0, <8.9.0 · fixed in 7.29.0, 8.9.0
GHSA-jr45-8vmc-qm54 · CVE-2026-14643 - CVSS 7.5 High
fast-uri vulnerable to host confusion via backslash authority introducer
- CWE-436
<2.4.4 || >=3.0.0, <3.1.5 || >=4.0.0, <4.1.2 · fixed in 2.4.4, 3.1.5, 4.1.2
GHSA-7p8r-x3mc-p8w7 · CVE-2026-18446 - CVSS 7.7 High
V 0.5.2 SSRF Bypass via Parser Differential in net.urllib and net.http
- v
- CWE-436
- CVSS 8.5 High
Openshift/oauth-proxy: openshift/oauth-proxy: underscore header smuggling enables identity impersonation on wsgi/php upstreams
- Red Hat OpenShift Container Platform 4.12
- Red Hat OpenShift Container Platform 4.13
- CWE-436
- CVSS 7.5 High
fast-uri vulnerable to host confusion via literal backslash authority delimiter
- CWE-436
>=2.3.1, <2.4.3 || >=3.0.0, <3.1.4 || >=4.0.0, <4.1.1 · fixed in 2.4.3, 3.1.4, 4.1.1
GHSA-v2hh-gcrm-f6hx · CVE-2026-16221 - CVSS 7.5 High
fast-uri vulnerable to host confusion via failed IDN canonicalization
- CWE-436
- CWE-551
>=2.3.1, <2.4.2 || >=3.0.0, <3.1.3 || >=4.0.0, <4.0.1 · fixed in 2.4.2, 3.1.3, 4.0.1
GHSA-4c8g-83qw-93j6 · CVE-2026-13676 - CVSS 4.2 Medium
guzzlehttp/psr7: Host Confusion via Weak URI Host Validation
- CWE-20
- CWE-436
<2.12.3 · fixed in 2.12.3
GHSA-c2w2-prh8-qm98 · CVE-2026-59882 - CVSS 9.8 CriticalCritical · KEV, CVSS 9+, CVSS 7+ and EPSSKEV
WordPress < 7.0.2 - REST API batch-route confusion and SQL injection issue leading to Remote Code Execution
- WordPress
- CWE-436
- CVSS 5.3 Medium
Capgo - Cross-Tenant Preview Namespace Collision via Non-Bijective Underscore Decoding
- Capgo
- CWE-436
- CVSS 4.0, no score published
netfoil has a domain name filter bypass via multiple questions
- CWE-436
- CWE-693
<0.3.0 · fixed in 0.3.0
GHSA-59qp-cfj3-rp64 - CVSS 9.1 CriticalCritical · CVSS 9+
@fastify/middie vulnerable to authorization bypass via encoded slash in path parameter values
- @fastify/middie
- CWE-436
- CVSS 8.8 High
@cedar-policy/authorization-for-expressjs has an authorization bypass via query string manipulation
- Broken access control
- CWE-436
<0.3.0 · fixed in 0.3.0
GHSA-g4w6-vmgf-xqvx · CVE-2026-49473 - CVSS 8.2 High
Remark42: Cross-Site Scripting (XSS) on /api/v1/img via content-type spoofing
- Cross-site scripting (XSS)
- CWE-436
>=1.6.0, <1.16.0 · fixed in 1.16.0
GHSA-4c8j-mgm4-qqvp · CVE-2026-48788 - CVSS 7.0 High
OctoPrint has possible file exfiltration via query parameters on upload endpoints
- Path traversal
- CWE-436
<1.11.8 || >=2.0.0rc1, <2.0.0rc3 · fixed in 1.11.8, 2.0.0rc3
GHSA-j4h9-pm27-4rfw · CVE-2026-54134 - CVSS 4.8 Medium
vLLM: image EXIF Rotation & PNG tRNS Transparency Not Normalized, Causing Mismatch Between Model Input and Expectations
- CWE-115
- CWE-436
>=0.11.0, <0.24.0 · fixed in 0.24.0
GHSA-8jr5-v98p-w75m · CVE-2026-12491 - CVSS 3.7 Low
python-multipart: Semicolon treated as querystring field separator enables parameter smuggling
- HTTP request smuggling
- CWE-436
<0.0.30 · fixed in 0.0.30
GHSA-6jv3-5f52-599m · CVE-2026-53538 - CVSS 3.7 Low
python-multipart: Content-Disposition parameter smuggling via RFC 2231/5987 extended parameters
- CWE-20
- CWE-436
<0.0.30 · fixed in 0.0.30
GHSA-vffw-93wf-4j4q · CVE-2026-53537 - CVSS 6.9 Medium
node-tar applies PAX size override to intermediary GNU long-name/long-link headers, causing tar parser interpretation differential (file smuggling)
- CWE-436
<7.5.16 · fixed in 7.5.16
GHSA-vmf3-w455-68vh · CVE-2026-53655 - CVSS 2.1 Low
TYPO3 HTML Sanitizer allows Cross-site Scripting
- Cross-site scripting (XSS)
- CWE-436
<2.3.2 · fixed in 2.3.2
GHSA-jvf5-rxvv-3mcg · CVE-2026-47344 - CVSS 8.3 High
SymfonyRuntime CVE-2024-50340 Patch Bypass: Web Requests Can Still Set APP_ENV/APP_DEBUG via parse_str/SAPI Argv Mismatch
- Other injection
- CWE-20
>=5.4.46, <5.4.52 || >=6.4.14, <6.4.40 || >=7.1.7, <7.4.12 || >=8.0.0, <8.0.12 · fixed in 5.4.52, 6.4.40, 7.4.12, 8.0.12
GHSA-fqc7-9xjw-jrh3 · CVE-2026-47767 - CVSS 5.4 Medium
LIBPNG: Chunk smuggling in push-mode APNG parser via unconsumed chunk body
- pnggroup libpng
- pnggroup libpng-apng
- CWE-436
- CVSS 2.3 Low
Symfony has an HtmlSanitizer allowLinkHosts() / allowMediaHosts() Bypass via URL-Parser Differentials and <area> Misclassification
- CWE-184
- CWE-436
>=6.1.0, <6.4.40 || >=7.0.0, <7.4.12 || >=8.0.0, <8.0.12 · fixed in 6.4.40, 7.4.12, 8.0.12
GHSA-qc95-4862-92fh · CVE-2026-45066 - CVSS 7.7 High
@hapi/content header parser has a parameter smuggling issue that allows upload-filter bypass via duplicate parameters
- CWE-436
<6.0.2 · fixed in 6.0.2
GHSA-36hh-x5p5-jgc8 · CVE-2026-44974 - CVSS 7.0 High
Fedify has an LD-Signature Bypass via JSON-LD Named-Graph Restructuring
- Weak cryptography or TLS
- CWE-180
<1.9.11 || >=1.10.0, <1.10.10 || >=2.0.0, <2.0.18 || >=2.1.0, <2.1.14 || >=2.2.0, <2.2.3 · fixed in 1.9.11, 1.10.10, 2.0.18, 2.1.14, 2.2.3
GHSA-9rfg-v8g9-9367 · CVE-2026-42462 - CVSS 6.9 Medium
SSRF allowlist bypass via percent-encoded host in hackney
- Server-side request forgery (SSRF)
- CWE-436
>=0.13.0, <4.0.1 · fixed in 4.0.1
GHSA-pj7v-xfvx-wmjq · CVE-2026-47076 - CVSS 8.7 High
authentik: SAML NameID XML Comment Injection Enables Authentication Bypass via Identifier Truncation
- authentik
- Other injection
- Authentication bypass
- CVSS 5.3 Medium
linux-entra-sso: PRT SSO cookie can leak to attacker-controlled hosts when broad host permissions are granted
- siemens linux-entra-sso
- Broken access control
- CWE-436
- CVSS 5.4 Medium
Next.js vulnerable to cache poisoning in React Server Component responses
- CWE-436
>=14.2.0, <15.5.16 || >=16.0.0, <16.2.5 · fixed in 15.5.16, 16.2.5
GHSA-wfc6-r584-vfw7 · CVE-2026-44576 - CVSS 7.5 High
fast-uri vulnerable to host confusion via percent-encoded authority delimiters
- CWE-140
- CWE-436
<2.4.1 || >=3.0.0, <3.1.2 · fixed in 2.4.1, 3.1.2
GHSA-v39h-62p7-jpjc · CVE-2026-6322 - CVSS 7.9 High
Server-side request forgery vulnerability in GitHub Enterprise Server notebook viewer via URL parser confusion
- GitHub Enterprise Server
- Server-side request forgery (SSRF)
- CWE-436
- CVSS 7.5 High
Flight: HTTP method override enabled by default, facilitating CSRF escalation and middleware bypass
- CWE-436
<3.18.1 · fixed in 3.18.1
GHSA-vxrr-w42w-w76g · CVE-2026-42551 - CVSS 6.5 Medium
Fiber's cache middleware default key generator ignores query string, causing response mix-up across distinct query parameters
- Information disclosure
- CWE-436
<3.2.0 · fixed in 3.2.0
GHSA-35hp-hqmv-8qg8 · CVE-2026-30246 - CVSS 7.8 High
Heimdall has an authorization bypass via path normalization mismatch
- Path traversal
- CWE-436
<0.17.14 · fixed in 0.17.14
GHSA-3q34-rx83-r6mq · CVE-2026-42274 - CVSS 7.8 High
Heimdall: Case-sensitive host matching may lead to policy bypass
- CWE-178
- CWE-436
<0.17.14 · fixed in 0.17.14
GHSA-72h4-mxfc-jx37 · CVE-2026-42273 - CVSS 7.8 High
Heimdall: Case-sensitive handling of URL-encoded slashes may lead to inconsistent path interpretation
- CWE-178
- CWE-436
<0.17.14 · fixed in 0.17.14
GHSA-43jv-5j4x-qv67 · CVE-2026-42272 - CVSS 5.1 Medium
justhtml has sanitization bypass in custom policies and programmatic DOM
- Cross-site scripting (XSS)
- Denial of service
<1.17.0 · fixed in 1.17.0
GHSA-vrx2-77f2-ww34 · CVE-2026-6827 - CVSS 9.1 CriticalCritical · CVSS 9+
@fastify/middie vulnerable to middleware authentication bypass in child plugin scopes
- CWE-436
<9.3.2 · fixed in 9.3.2
GHSA-72c6-fx6q-fr5w · CVE-2026-6270 - CVSS 7.4 High
@fastify/middie vulnerable to middleware bypass via deprecated ignoreDuplicateSlashes option
- CWE-436
<9.3.2 · fixed in 9.3.2
GHSA-v9ww-2j6r-98q6 · CVE-2026-33804 - CVSS 9.1 CriticalCritical · CVSS 9+
Official Clerk JavaScript SDKs: Middleware-based route protection bypass
- Broken access control
- CWE-436
>=0.0.1, <1.5.7 || >=2.0.0-snapshot.v20241206174604, <2.17.10 || >=3.0.0, <3.0.15 · fixed in 1.5.7, 2.17.10, 3.0.15
GHSA-vqx2-fgx2-5wq9 · CVE-2026-41248