Advisory record · GHSA-j4jc-cq9h-xrhr

Apache Airflow's Backfill API authorized a request against a Dag id supplied by the caller whenever the `backfill_id` path segment failed to parse. The authorization dependency parsed it with `int(...

CVSS 7.5 HighEPSS 0.0042 · 36th percentile

Published by the GitHub Advisory Database at 12 Aug 2026, 16:17 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
apache-airflowPyPI<3.3.13.3.1
Identifiers
GHSA-j4jc-cq9h-xrhr · BIT-airflow-2026-68968 · CVE-2026-68968 · PYSEC-2026-3710
Weakness (CWE)
CWE-436
Published
12 Aug 2026
Updated
15 Oct 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

Apache Airflow versions before 3.3.1 are vulnerable in the Backfill API, where the authorization check and the route handler parsed the backfill id differently. An authenticated user with edit permission on any one Dag can read, pause and cancel backfills belonging to other Dags, including moving their queued runs to failed. Upgrade apache-airflow to 3.3.1 or later, which parses the backfill id consistently.

Written 1 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
7.5 High 3.1 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N OSV
  • CISA KEV Not listed.
  • EPSS 0.0042, the 36th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 12 Aug 2026, 15:27 UTC Confirmed by the CVE List
  2. 12 Aug 2026, 16:17 UTC Confirmed by NVD
  3. 31 Oct 2026, 14:08 UTC First seen by agentprime
  4. 31 Oct 2026, 14:08 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.