Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
The flightphp/core Packagist package, versions before 3.18.1, honors the X-HTTP-Method-Override header and the _method parameter on any HTTP verb, including GET, so a GET request can be treated as DELETE or PUT. An attacker can exploit this with a crafted link or page that triggers a request on a victim's browser, which can reach destructive routes and bypass middleware gated on unsafe verbs. Upgrade to 3.18.1, where the new flight.allow_method_override setting can be set to false to disable both override methods.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 7.5 | High | 3.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0035, the 28th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:25 UTC First seen by agentprime
- 31 Oct 2026, 14:25 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-vxrr-w42w-w76g
- OSV: GHSA-vxrr-w42w-w76g
- github.com/flightphp/core/security/advisories/GHSA-vxrr-w42w-w76g
- nvd.nist.gov/vuln/detail/CVE-2026-42551
- github.com/flightphp/core/commit/b8dd23aaa828cb289fa3c84e75b2a3717cab50b0
- github.com/flightphp/core
- github.com/flightphp/core/releases/tag/v3.18.1