Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Vulnerable versions of the zstd crate are 0.13.2 up to but not including 0.13.4, and 0.14.0 up to but not including 0.14.3. Applications that reuse one encoder or decoder context across streams can have data from an abandoned stream carried into the next one, including plaintext from one user appearing in another's output. Upgrade to zstd 0.13.4 or 0.14.3, or later.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
No source has published a CVSS score for this record yet.
- CISA KEV Not listed.
- EPSS No score.
Timeline
- 31 Oct 2026, 14:24 UTC First seen by agentprime
- 31 Oct 2026, 14:24 UTC Confirmed by OSV