Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
The negentropy crate on crates.io, versions 0.2.0 before 0.4.4 and 0.5.0 before 0.5.2, is vulnerable with the default std feature enabled. An unauthenticated remote attacker can send a small malformed reconciliation message that forces a huge memory allocation, aborting the application. Upgrade to negentropy 0.4.4 or 0.5.2. A message-size limit alone does not prevent this.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 7.5 | High | 3.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H | OSV |
- CISA KEV Not listed.
- EPSS No score.
Timeline
- 31 Oct 2026, 14:24 UTC First seen by agentprime
- 31 Oct 2026, 14:24 UTC Confirmed by OSV