Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Apache Airflow's Snowflake provider (apache-airflow-providers-snowflake) before 6.18.0 does not validate the connection's account and region fields before building request URLs from them. A user who can edit a Snowflake connection, but cannot read its stored secrets, can cause an existing Dag using that connection to send a valid Snowflake token to a host of the attacker's choosing. Upgrade to apache-airflow-providers-snowflake 6.18.0 or later, which rejects account and region values containing characters other than letters, digits, dots, underscores and hyphens.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 6.3 | Medium | 3.1 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L | OSV |
- CISA KEV Not listed.
- EPSS 0.0043, the 37th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:08 UTC First seen by agentprime
- 31 Oct 2026, 14:08 UTC Confirmed by OSV