Advisory record · GHSA-xxfm-vmcf-g33f

Improper Handling of Insufficient Permissions in `wagtail.contrib.settings`

CVSS 5.5 MediumEPSS 0.0033 · 26th percentile

Published by the GitHub Advisory Database at 2 Jun 2024, 22:28 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
wagtailPyPI>=6.0.0, <6.0.5 || >=6.1.0, <6.1.26.0.5, 6.1.2
Identifiers
GHSA-xxfm-vmcf-g33f · CVE-2024-35228 · PYSEC-2026-2032
Weakness (CWE)
CWE-280
Published
2 Jun 2024
Updated
10 Sept 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

The wagtail package versions 6.0.0 up to 6.0.5 and 6.1.0 up to 6.1.2 are affected by a permission check flaw in the wagtail.contrib.settings module. A user with Wagtail admin access who knows the edit URL for a settings model can view and update that setting without having been granted permission for it. Upgrade to wagtail 6.0.5 or 6.1.2; the source lists no workaround.

Written 5 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
5.5 Medium 3.1 CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:H/A:N CNA (GitHub_M)
  • CISA KEV Not listed.
  • EPSS 0.0033, the 26th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 14:35 UTC First seen by agentprime
  2. 31 Oct 2026, 14:35 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.