Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Vikunja (code.vikunja.io/api) versions 2.5.0 up to but not including 2.6.0 are vulnerable. A low-privileged authenticated user can send a task-list request with a filter expression nested thousands of levels deep, which makes the server parse it recursively until memory is exhausted and the API process is killed, denying service to all users. Upgrade to version 2.6.0 or later.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 7.1 | High | 4.0 | CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N | CNA (VulnCheck) |
- CISA KEV Not listed.
- EPSS 0.0044, the 38th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:11 UTC First seen by agentprime
- 31 Oct 2026, 14:11 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-xxc3-xpmc-vmvr
- OSV: GHSA-xxc3-xpmc-vmvr
- github.com/go-vikunja/vikunja/security/advisories/GHSA-xxc3-xpmc-vmvr
- nvd.nist.gov/vuln/detail/CVE-2026-91968
- github.com/go-vikunja/vikunja/pull/3688
- github.com/go-vikunja/vikunja
- github.com/go-vikunja/vikunja/releases/tag/v2.6.0
- www.vulncheck.com/advisories/vikunja-before-2.6.0-denial-of-service-via-unbounded-filter-recursion