Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Versions of tracing-subscriber before 0.3.20 are vulnerable to ANSI escape sequence injection: untrusted user input logged by the library can carry escape sequences into terminal output. An attacker who can get such input logged could alter terminal titles or screen contents, and possibly exploit flaws in a terminal emulator. Upgrade tracing-subscriber to 0.3.20 or later, which escapes ANSI control characters in user input.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 2.3 | Low | 4.0 | CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0034, the 27th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:24 UTC First seen by agentprime
- 31 Oct 2026, 14:24 UTC Confirmed by OSV