Advisory record · GHSA-xvq9-wjp8-hwqf

i18next-http-backend incomplete URL validation permits SSRF

CVSS 3.7 LowEPSS 0.0029 · 21st percentile

Published by the GitHub Advisory Database at 6 Oct 2026, 15:33 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
i18next-http-backendnpm<4.0.24.0.2
Identifiers
GHSA-xvq9-wjp8-hwqf · CVE-2026-105800
Weakness (CWE)
CWE-74 · CWE-918
Published
6 Oct 2026
Updated
24 Oct 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

i18next-http-backend versions before 4.0.2 are vulnerable to server-side request forgery because URL validation of language and namespace values is incomplete. An attacker who controls those values, in a loadPath template that begins with the placeholder, can make the backend request an unintended origin. Upgrade to 4.0.2, which rejects colons in language and namespace values.

Written 31 Oct 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
3.7 Low 3.1 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N CNA (GitHub_M)
  • CISA KEV Not listed.
  • EPSS 0.0029, the 21st percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 13:33 UTC First seen by agentprime
  2. 31 Oct 2026, 13:33 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.