Advisory record · GHSA-xr22-8pqp-gwfh

Poly1305 panics or computes a wrong tag on attacker-chosen messages of 64 bytes or more

CVSS 7.5 High

Published by the GitHub Advisory Database at 9 Oct 2026, 12:00 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
ic-ciphercrates.io>=0.2.5, <0.2.200.2.20
Identifiers
GHSA-xr22-8pqp-gwfh · RUSTSEC-2026-0337
Published
9 Oct 2026
Updated
12 Oct 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

Poly1305 and ChaCha20-Poly1305 in ic-cipher versions 0.2.5 through 0.2.19 can panic or compute a wrong authentication tag on messages of 64 bytes or more. An attacker who can deliver a ChaCha20-Poly1305 ciphertext for opening can trigger the panic, which ends the process under panic = "abort" in builds with overflow checks on, and no key is needed. Upgrade ic-cipher to 0.2.20.

Written 3 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
7.5 High 3.1 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H OSV
  • CISA KEV Not listed.
  • EPSS No score.

Timeline

  1. 31 Oct 2026, 14:24 UTC First seen by agentprime
  2. 31 Oct 2026, 14:24 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.