Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
GHSA-xpv3-w29h-x7cv concerns oauthlib versions 3.0.0 up to but not including 4.0.0, where the PKCE code_verifier check uses a non-constant-time string comparison that may leak timing information. An attacker would need to repeatedly send token requests and measure response times, and the source notes that practical exploitation is limited. Upgrade to oauthlib 4.0.0, which is listed as the fixed version.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 6.8 | Medium | 3.1 | CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0024, the 15th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:08 UTC First seen by agentprime
- 31 Oct 2026, 14:08 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-xpv3-w29h-x7cv
- OSV: GHSA-xpv3-w29h-x7cv
- github.com/oauthlib/oauthlib/security/advisories/GHSA-xpv3-w29h-x7cv
- nvd.nist.gov/vuln/detail/CVE-2026-49265
- github.com/oauthlib/oauthlib/pull/963
- github.com/oauthlib/oauthlib/commit/40b0ab56da3682c2484a4b78bbff309f8025d950
- github.com/oauthlib/oauthlib
- github.com/pypa/advisory-database/tree/main/vulns/oauthlib/PYSEC-2026-4114.yaml