Advisory record · GHSA-xp7p-3gx7-j6wx

calibre-web is vulnerable to Business Logic Errors

CVSS 7.7 HighEPSS 0.014 · 72nd percentile

Published by the GitHub Advisory Database at 21 Jan 2022, 23:44 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
calibrewebPyPI<0.6.150.6.15
Identifiers
GHSA-xp7p-3gx7-j6wx · CVE-2021-4171 · PYSEC-2026-307
Weakness (CWE)
CWE-840
Published
21 Jan 2022
Updated
27 Oct 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

The calibreweb package on PyPI is affected in versions before 0.6.15. The source gives few details about the specific business logic error, and it does not describe what an attacker needs or what they could do, though the listed CVSS 3.1 base score is 9.8 (CRITICAL). Upgrade to calibreweb 0.6.15, which is the listed fixed version.

Written 31 Oct 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
7.7 High 3.0 CVSS:3.0/AV:N/AC:H/PR:H/UI:N/S:C/C:N/I:H/A:H CNA (@huntrdev)
  • CISA KEV Not listed.
  • EPSS 0.014, the 72nd percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 14:07 UTC First seen by agentprime
  2. 31 Oct 2026, 14:07 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.