Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Moodle versions before 4.1.13, from 4.2.0-beta before 4.2.10, from 4.3.0-beta before 4.3.7, and from 4.4.0-beta before 4.4.3 are affected. In the Lesson activity, a password check using loose comparison can be bypassed when the password is set to a "magic hash" value. Upgrade to 4.1.13, 4.2.10, 4.3.7, 4.4.3, or later.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 5.4 | Medium | 3.1 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N | GitHub Advisory Database |
- CISA KEV Not listed.
- EPSS 0.0041, the 35th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:27 UTC First seen by agentprime
- 31 Oct 2026, 14:27 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-xfv7-h2qg-rjm7
- OSV: GHSA-xfv7-h2qg-rjm7
- nvd.nist.gov/vuln/detail/CVE-2024-45691
- github.com/moodle/moodle/commit/3fc1073d304f660d2552b591c5fb92547ed01e92
- bugzilla.redhat.com/show_bug.cgi?id=2309940
- github.com/moodle/moodle
- moodle.org/mod/forum/discuss.php?d=461897#p1854494
- moodle.org/security