Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Django versions 4.2 before 4.2.14 and 5.0 before 5.0.7 are vulnerable. A remote attacker can determine which user accounts exist by timing login requests for users who have an unusable password. Upgrade to Django 4.2.14 or 5.0.7.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 5.3 | Medium | 3.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N | GitHub Advisory Database |
- CISA KEV Not listed.
- EPSS 0.0089, the 59th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:35 UTC First seen by agentprime
- 31 Oct 2026, 14:35 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-x7q2-wr7g-xqmf
- OSV: GHSA-x7q2-wr7g-xqmf
- nvd.nist.gov/vuln/detail/CVE-2024-39329
- github.com/django/django/commit/07cefdee4a9d1fcd9a3a631cbd07c78defd1923b
- github.com/django/django/commit/156d3186c96e3ec2ca73b8b25dc2ef366e38df14
- docs.djangoproject.com/en/dev/releases/security
- github.com/django/django
- github.com/pypa/advisory-database/tree/main/vulns/django/PYSEC-2024-57.yaml
- groups.google.com/forum/#%21forum/django-announce
- security.netapp.com/advisory/ntap-20240808-0005
- www.djangoproject.com/weblog/2024/jul/09/security-releases