Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
The default unsafe-operation plugin in the npm package simple-git, versions 3.15.0 before 4.0.1, does not block Git trailer command configuration. An attacker who can pass untrusted values into instance config options or Git inline configuration arguments can cause a shell command to run with the permissions of the Node.js process. Upgrade to simple-git 4.0.1, the fixed version.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 9.2 | Critical | 4.0 | CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0037, the 31st percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 13:34 UTC First seen by agentprime
- 31 Oct 2026, 13:34 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-x6jw-m9v5-85vh
- OSV: GHSA-x6jw-m9v5-85vh
- github.com/steveukx/git-js/security/advisories/GHSA-x6jw-m9v5-85vh
- nvd.nist.gov/vuln/detail/CVE-2026-102828
- github.com/steveukx/git-js/pull/1198
- github.com/steveukx/git-js/commit/d762810c13b331ff1e5eb24c0b434646d2a8d1b3
- github.com/steveukx/git-js
- github.com/steveukx/git-js/releases/tag/[email protected]