Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
The Kirby CMS package getkirby/cms is affected in versions before 3.5.8.3, from 3.6.0 before 3.6.6.3, from 3.7.0 before 3.7.5.2, from 3.8.0 before 3.8.4.1, and from 3.9.0 before 3.9.6. An attacker who is an authenticated Panel user, or a visitor on a site that lets outsiders update content files through forms, can inject a Unicode BOM into a field separator to add or overwrite fields that were defined above the user-writable field. Upgrade to 3.5.8.3, 3.6.6.3, 3.7.5.2, 3.8.4.1, 3.9.6, or a later version.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 7.1 | High | 3.1 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:L | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0092, the 60th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:05 UTC First seen by agentprime
- 31 Oct 2026, 14:05 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-x5mr-p6v4-wp93
- OSV: GHSA-x5mr-p6v4-wp93
- github.com/getkirby/kirby/security/advisories/GHSA-x5mr-p6v4-wp93
- nvd.nist.gov/vuln/detail/CVE-2023-38488
- github.com/getkirby/kirby/commit/a1e0f81c799ddae1af91cf37216f8ded9cb93540
- github.com/getkirby/kirby
- github.com/getkirby/kirby/releases/tag/3.5.8.3
- github.com/getkirby/kirby/releases/tag/3.6.6.3
- github.com/getkirby/kirby/releases/tag/3.7.5.2
- github.com/getkirby/kirby/releases/tag/3.8.4.1
- github.com/getkirby/kirby/releases/tag/3.9.6