Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
CodeIgniter4 framework versions before 4.5.8 do not validate header names and values passed to the Header class. An attacker who can supply header input to the application can build malformed headers, which may cause errors or invalid HTTP requests and, in some cases, lead to denial of service if a web application firewall blocks the application's traffic. Upgrade to version 4.5.8 or later. As a workaround, validate header names and values that come from user input before passing them to the Header class.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 5.3 | Medium | 3.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0051, the 43rd percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:26 UTC First seen by agentprime
- 31 Oct 2026, 14:26 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-x5mq-jjr3-vmx6
- OSV: GHSA-x5mq-jjr3-vmx6
- github.com/codeigniter4/CodeIgniter4/security/advisories/GHSA-x5mq-jjr3-vmx6
- nvd.nist.gov/vuln/detail/CVE-2025-24013
- github.com/codeigniter4/CodeIgniter4/commit/5f8aa24280fb09947897d6b322bf1f0e038b13b6
- datatracker.ietf.org/doc/html/rfc7230#section-3.2
- github.com/advisories/GHSA-wxmh-65f7-jcvw
- github.com/codeigniter4/CodeIgniter4