Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Qwik packages @builder.io/qwik before 1.20.0 and @qwik.dev/core before 2.0.0-beta37 are affected. An unauthenticated attacker can send a single HTTP request that crashes a Qwik server running in its default configuration, and repeated requests can keep every replica down. Upgrade @builder.io/qwik to 1.20.0 or @qwik.dev/core to 2.0.0-beta37.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 8.7 | High | 4.0 | CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0052, the 44th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 13:33 UTC First seen by agentprime
- 31 Oct 2026, 13:33 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-x586-xvc8-g7q6
- OSV: GHSA-x586-xvc8-g7q6
- github.com/QwikDev/qwik/security/advisories/GHSA-x586-xvc8-g7q6
- nvd.nist.gov/vuln/detail/CVE-2026-84994
- github.com/QwikDev/qwik/pull/8655
- github.com/QwikDev/qwik/commit/c1e7444402f9592b5cf9096e10bf303ab4640511
- github.com/QwikDev/qwik
- github.com/QwikDev/qwik/releases/tag/@builder.io/[email protected]