Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
The vLLM package (PyPI) versions from 0.16.0 before 0.32.0 are affected: the /v1/responses endpoint accepts request-level chat_template_kwargs and does not apply the --trust-request-chat-template gate that protects other endpoints, so a request-supplied Jinja chat template can be used even when the trust flag is disabled. An authenticated caller who can submit Responses requests can do this, and the source says the related impact is CPU and memory exhaustion from request-controlled templates. Upgrade to vLLM 0.32.0 or later, which is listed as the fixed version.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 6.5 | Medium | 3.1 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0035, the 28th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:07 UTC First seen by agentprime
- 31 Oct 2026, 14:07 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-x567-49g5-p4cf
- OSV: GHSA-x567-49g5-p4cf
- github.com/vllm-project/vllm/security/advisories/GHSA-x567-49g5-p4cf
- nvd.nist.gov/vuln/detail/CVE-2026-115918
- github.com/vllm-project/vllm/pull/50300
- github.com/vllm-project/vllm/commit/cff08b461e086523cee8bba5bd3c66d302625134
- github.com/vllm-project/vllm
- github.com/vllm-project/vllm/releases/tag/v0.32.0