Advisory record · GHSA-x4r9-gmw3-hxww

GeoServer has a Server-Side Request Forgery (SSRF) Vulnerability in its XML Entity Resolution

CVSS 6.5 MediumEPSS 0.0029 · 21st percentile

Published by the GitHub Advisory Database at 12 Jun 2026, 18:23 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
org.geoserver.web:gs-web-appMaven<2.26.4 || >=2.27.0, <2.27.32.26.4, 2.27.3
org.geoserver:gs-mainMaven<2.26.4 || >=2.27.0, <2.27.32.26.4, 2.27.3
Identifiers
GHSA-x4r9-gmw3-hxww · CVE-2025-58175
Weakness (CWE)
CWE-20 · CWE-611 · CWE-918
Published
12 Jun 2026
Updated
12 Jun 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

GeoServer versions below 2.26.4 and from 2.27.0 up to (but not including) 2.27.3, including the gs-web-app and gs-main Maven packages, are vulnerable to unauthenticated Server-Side Request Forgery through XML entity resolution when the ENTITY_RESOLUTION_ALLOWLIST is in use and a proxy base URL is configured. An attacker can cause GeoServer to make requests to unintended locations. Upgrade to 2.26.4, 2.27.3, or later. As a workaround, if the proxy base URL has no path, add a trailing slash to it.

Written 3 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
6.5 Medium 3.1 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:L CNA (GitHub_M)
  • CISA KEV Not listed.
  • EPSS 0.0029, the 21st percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 14:20 UTC First seen by agentprime
  2. 31 Oct 2026, 14:20 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.