Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
The pypdf PyPI package, versions before 6.21.3, has a flaw in how it parses cross-reference streams that can lead to large memory usage. An attacker can exploit it by crafting a PDF file that the victim then opens with pypdf, which requires a user to open such a file. The fix is to upgrade to pypdf 6.21.3; if an upgrade is not yet possible, the source suggests applying the changes from the referenced pull request.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 7.1 | High | 4.0 | CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0027, the 19th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 29 Oct 2026, 21:17 UTC Confirmed by NVD
- 31 Oct 2026, 14:07 UTC First seen by agentprime
- 31 Oct 2026, 14:07 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-x3rh-gjgm-fmqc
- OSV: GHSA-x3rh-gjgm-fmqc
- github.com/py-pdf/pypdf/security/advisories/GHSA-x3rh-gjgm-fmqc
- nvd.nist.gov/vuln/detail/CVE-2026-119209
- github.com/py-pdf/pypdf/pull/4269
- github.com/py-pdf/pypdf/commit/a93fe3a901fd00af38f0a105c3ba7175fa72dcb4
- github.com/py-pdf/pypdf
- github.com/py-pdf/pypdf/releases/tag/6.21.3