Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Moodle versions 2.0.x before 2.0.4 and 2.1.x before 2.1.1 are affected. The theme implementation duplicates caching of CSS and JavaScript content, which lets remote attackers bypass access restrictions and write to the operating system's temporary directory through unspecified vectors. Upgrade to Moodle 2.0.4 or 2.1.1.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
No source has published a CVSS score for this record yet.
- CISA KEV Not listed.
- EPSS 0.024, the 84th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:32 UTC First seen by agentprime
- 31 Oct 2026, 14:32 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-wxvp-8q8h-r6rr
- OSV: GHSA-wxvp-8q8h-r6rr
- nvd.nist.gov/vuln/detail/CVE-2011-4293
- github.com/moodle/moodle/commit/05f4555422278190ec24a88466ac43c914a7e5d6
- github.com/moodle/moodle/commit/9a380fbb53429713b3c422a3146456dc97205329
- github.com/moodle/moodle/commit/e1c2a211f259821910be2cba23679d4176fb00a3
- github.com/moodle/moodle
- git.moodle.org/gw?p=moodle.git;a=commit;h=e1c2a211f259821910be2cba23679d4176fb00a3
- moodle.org/mod/forum/discuss.php?d=182736
- openwall.com/lists/oss-security/2011/11/14/1