Advisory record · GHSA-wr9h-g72x-mwhm

vLLM is vulnerable to timing attack at bearer auth

CVSS 7.5 HighEPSS 0.0057 · 47th percentile

Published by the GitHub Advisory Database at 7 Oct 2025, 17:24 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
vllmPyPI<0.11.00.11.0
Identifiers
GHSA-wr9h-g72x-mwhm · CVE-2025-59425 · PYSEC-2026-2026
Weakness (CWE)
CWE-385
Published
7 Oct 2025
Updated
10 Sept 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

vLLM versions before 0.11.0 are vulnerable to a timing attack on API key validation, because the key check used a string comparison that takes longer the more leading characters match. An attacker who can send many requests to a deployment using vLLM's built-in API key authentication could use timing measurements to recover a valid key more efficiently than brute force. Upgrade to vLLM 0.11.0 or later.

Written 5 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
7.5 High 3.1 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N CNA (GitHub_M)
  • CISA KEV Not listed.
  • EPSS 0.0057, the 47th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 14:34 UTC First seen by agentprime
  2. 31 Oct 2026, 14:34 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.