Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
The sharp npm package versions below 0.35.5 are affected by a memory-related vulnerability in its bundled librsvg dependency, which the source says can lead to remote code execution on glibc-based Linux under certain runtime conditions. The source does not describe what an attacker must do beforehand, such as supplying a crafted SVG image, though sharp's decoding of SVG images is the relevant path. Upgrade sharp to 0.35.5 or later, which provides librsvg 2.63.2; users with a globally installed librsvg should move to librsvg 2.63.2.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 8.9 | High | 4.0 | CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H | CNA (VulnCheck) |
- CISA KEV Not listed.
- EPSS 0.0013, the 2nd percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 13:33 UTC First seen by agentprime
- 31 Oct 2026, 13:33 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-wq5f-xc86-pv6w
- OSV: GHSA-wq5f-xc86-pv6w
- github.com/lovell/sharp/security/advisories/GHSA-wq5f-xc86-pv6w
- github.com/lovell/sharp/commit/96de105d9d36ab04c76c2b78b97255171630d236
- github.com/lovell/sharp
- github.com/lovell/sharp/releases/tag/v0.35.5
- gitlab.gnome.org/GNOME/librsvg/-/work_items/1241
- www.cve.org/CVERecord?id=CVE-2026-96889