Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Excelize (github.com/xuri/excelize/v2) versions 2.8.1 up to but not including 2.11.1-0.20260911060113-ea12859e43c6 are vulnerable. A crafted workbook with two mutually referencing ANCHORARRAY dynamic array formulas causes unbounded recursion during formula evaluation, which ends in a fatal Go stack overflow that aborts the whole process. An attacker only needs to supply such a workbook to an application that evaluates its cells, such as through CalcCellValue, AddPivotTable, or AddPicture. Upgrade to 2.11.1-0.20260911060113-ea12859e43c6 or later. No configuration workaround is listed.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 7.5 | High | 3.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0037, the 31st percentile, on 8 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:11 UTC First seen by agentprime
- 31 Oct 2026, 14:11 UTC Confirmed by OSV