Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Apache Tomcat (tomcat-embed-core and tomcat-coyote) versions 11.0.0-M1 through 11.0.0-M20, 10.1.0-M1 through 10.1.24, 9.0.0-M1 through 9.0.89, and 8.5.0 through 8.5.100 are affected. Tomcat mishandles excessive HTTP headers on HTTP/2 streams, so connections that should close can remain open, which can lead to denial of service. The source does not describe the attacker's required access in detail. Upgrade to 11.0.0-M21, 10.1.25, or 9.0.90.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 7.5 | High | 3.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H | GitHub Advisory Database |
- CISA KEV Not listed.
- EPSS 0.046, the 91st percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:17 UTC First seen by agentprime
- 31 Oct 2026, 14:17 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-wm9w-rjj3-j356
- OSV: GHSA-wm9w-rjj3-j356
- nvd.nist.gov/vuln/detail/CVE-2024-34750
- github.com/apache/tomcat/commit/2344a4c0d03e307ba6b8ab6dc8b894cc8bac63f2
- github.com/apache/tomcat/commit/2afae300c9ac9c0e516e2e9de580847d925365c3
- github.com/apache/tomcat/commit/9fec9a82887853402833a80b584e3762c7423f5f
- github.com/apache/tomcat
- lists.apache.org/thread/4kqf0bc9gxymjc2x7v3p7dvplnl77y8l
- lists.debian.org/debian-lts-announce/2025/07/msg00009.html
- security.netapp.com/advisory/ntap-20240816-0004
- tomcat.apache.org/security-10.html
- tomcat.apache.org/security-11.html
- tomcat.apache.org/security-9.html