Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
netius versions prior to 1.17.58 are vulnerable to HTTP request smuggling caused by incorrect parsing of the Transfer-Encoding header, which could allow CL:TE or TE:TE attacks. The source does not describe what access an attacker needs or the full impact. Upgrade netius to version 1.17.58 or later.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 6.1 | Medium | 3.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N | GitHub Advisory Database |
- CISA KEV Not listed.
- EPSS 0.0084, the 58th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:37 UTC First seen by agentprime
- 31 Oct 2026, 14:37 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-wm2m-xrrp-j74c
- OSV: GHSA-wm2m-xrrp-j74c
- nvd.nist.gov/vuln/detail/CVE-2020-7655
- github.com/hivesolutions/netius/commit/9830881ef68328f8ea9c7901db1d11690677e7d1
- github.com/advisories/GHSA-wm2m-xrrp-j74c
- github.com/hivesolutions/netius
- github.com/pypa/advisory-database/tree/main/vulns/netius/PYSEC-2020-242.yaml
- snyk.io/vuln/SNYK-PYTHON-NETIUS-569141