Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Kirby CMS (Packagist getkirby/cms) versions before 4.9.4, and from 5.0.0-alpha.1 up to but not including 5.4.4, are affected. Sites with no configured user accounts that run behind a reverse proxy setting the Forwarded for=, X-Client-IP, or X-Real-IP header could have the Panel installed, creating an admin account, by a request from a remote IP address without authentication. Upgrade to Kirby 4.9.4 or 5.4.4, or a later version; for older Kirby 3 sites, create the initial admin account yourself or disable the REST API.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 9.1 | Critical | 4.0 | CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0074, the 54th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:00 UTC First seen by agentprime
- 31 Oct 2026, 14:00 UTC Confirmed by OSV