Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Netty's io.netty:netty-codec-haproxy package is vulnerable in versions 4.2.0.Final up to 4.2.16.Final and in versions before 4.1.136.Final. The HAProxy V1 encoder does not check AF_UNIX addresses for CRLF characters, so an application that builds those addresses from untrusted input can let an attacker inject a second PROXY header line, which can spoof the client IP to a backend. Upgrade to 4.2.16.Final or 4.1.136.Final, or later. The source gives few details on the exact preconditions beyond the affected use cases.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 5.5 | Medium | 3.1 | CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0016, the 5th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:16 UTC First seen by agentprime
- 31 Oct 2026, 14:16 UTC Confirmed by OSV