Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Jetty's http2-server package (Maven org.eclipse.jetty.http2:http2-server) versions before 9.4.47, from 10.0.0 before 10.0.10, and from 11.0.0 before 11.0.10 are affected. A remote client can send invalid HTTP/2 requests, such as ones with invalid URIs, and exhaust the flow control window or congest the TCP connection so that the selector threads block while writing error responses, making the server unresponsive. Upgrade to 9.4.47, 10.0.10, or 11.0.10. The source lists no workaround within Jetty; it suggests filtering such requests before they reach Jetty, for example in a proxy.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 7.5 | High | 3.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H | CNA (eclipse) |
- CISA KEV Not listed.
- EPSS 0.026, the 85th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:19 UTC First seen by agentprime
- 31 Oct 2026, 14:19 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-wgmr-mf83-7x4j
- OSV: GHSA-wgmr-mf83-7x4j
- github.com/eclipse/jetty.project/security/advisories/GHSA-wgmr-mf83-7x4j
- nvd.nist.gov/vuln/detail/CVE-2022-2048
- github.com/eclipse/jetty.project
- lists.debian.org/debian-lts-announce/2022/08/msg00011.html
- security.netapp.com/advisory/ntap-20220901-0006
- www.debian.org/security/2022/dsa-5198
- www.openwall.com/lists/oss-security/2022/09/09/2