Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
OpenAM (Maven package org.openidentityplatform.openam:openam-core) versions below 16.1.2 are affected. An unauthenticated attacker with network access to the /authservice endpoint can supply an XML element naming an arbitrary Java class, which the server loads and instantiates, allowing code execution on the server. Upgrade to version 16.1.2. Until then, restrict external network access to /authservice; enabling sunRemoteAuthSecurityEnabled does not mitigate this issue.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 9.8 | Critical | 3.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.011, the 64th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:19 UTC First seen by agentprime
- 31 Oct 2026, 14:19 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-wg5r-wc3x-39vc
- OSV: GHSA-wg5r-wc3x-39vc
- github.com/OpenIdentityPlatform/OpenAM/security/advisories/GHSA-wg5r-wc3x-39vc
- github.com/OpenIdentityPlatform/OpenAM/commit/edcf968cad91a78b932dba4ad559ef94cbf35f5a
- github.com/OpenIdentityPlatform/OpenAM
- github.com/OpenIdentityPlatform/OpenAM/releases/tag/16.1.2