Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Pion DTLS (github.com/pion/dtls/v3) versions before 3.1.4 are vulnerable to a denial of service caused by a panic while parsing a crafted ECDHE_PSK ServerKeyExchange message. A remote attacker can trigger the panic over the network, crashing the affected process. Upgrade to version 3.1.4 or later; no workaround is available.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 6.3 | Medium | 4.0 | CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0054, the 45th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:13 UTC First seen by agentprime
- 31 Oct 2026, 14:13 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-wg4g-wm44-ch5j
- OSV: GHSA-wg4g-wm44-ch5j
- github.com/pion/dtls/security/advisories/GHSA-wg4g-wm44-ch5j
- nvd.nist.gov/vuln/detail/CVE-2026-54908
- github.com/pion/dtls/pull/839
- github.com/pion/dtls/commit/49458d604a4f3ebce1bf9587a0f3e5f3f6b4a55e
- github.com/pion/dtls
- github.com/pion/dtls/releases/tag/v3.1.3