Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
GeoServer versions before 2.27.0 (org.geoserver:gs-main, org.geoserver:gs-wms and org.geoserver.web:gs-web-app) are vulnerable to server-side template injection through FreeMarker templates. An authenticated administrator who uploads a crafted template can run OS commands and read or write arbitrary files on the server. Upgrade to GeoServer 2.27.0 or later, which adds application properties that restrict the objects templates can access.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 7.2 | High | 3.1 | CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H | GitHub Advisory Database |
- CISA KEV Not listed.
- EPSS No score.
Timeline
- 31 Oct 2026, 14:19 UTC First seen by agentprime
- 31 Oct 2026, 14:19 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-wf6j-gr27-g7ch
- OSV: GHSA-wf6j-gr27-g7ch
- github.com/geoserver/geoserver/security/advisories/GHSA-wf6j-gr27-g7ch
- github.com/geoserver/geoserver/pull/8164
- docs.geoserver.org/latest/en/user/tutorials/GetFeatureInfo/html/#accessing-instance-methods
- github.com/geoserver/geoserver
- osgeo-org.atlassian.net/browse/GEOS-11645
- osgeo-org.atlassian.net/browse/GEOS-11777