Advisory record · GHSA-wf6j-7hvr-gr93

Hydra legacy target blacklist permits unsafe PyYAML loading

CVSS 7.8 High

Published by the GitHub Advisory Database at 27 Oct 2026, 17:08 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
hydra-corePyPI>=1.3.6, <1.3.8 || >=1.4.0.dev9, <1.4.0rc31.3.8, 1.4.0rc3
Identifiers
GHSA-wf6j-7hvr-gr93
Weakness (CWE)
CWE-184
Published
27 Oct 2026
Updated
27 Oct 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

Hydra (hydra-core on PyPI) versions 1.3.6 through 1.3.7 and the 1.4 prereleases from 1.4.0.dev9 before 1.4.0rc3 have a legacy target blacklist that leaves PyYAML's unsafe loading functions unblocked. An attacker who controls the targets and arguments an application passes to instantiate() can run Python code in the application's process, for example through a YAML config stream, such as one bundled in a third-party model. Upgrade to hydra-core 1.3.8 or 1.4.0rc3; the source also advises not passing untrusted configuration to instantiate() or call().

Written 31 Oct 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
7.8 High 3.1 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H GitHub Advisory Database
  • CISA KEV Not listed.
  • EPSS No score.

Timeline

  1. 31 Oct 2026, 14:07 UTC First seen by agentprime
  2. 31 Oct 2026, 14:07 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.