Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
GHSA-w9x9-j56r-h98r affects the npm package @eeacms/volto-chatbot in versions before 2.0.4. Its Express middleware forwards unauthenticated requests on the /_v1_da/ path to the configured Danswer API, attaching the server's own Danswer credentials. An unauthenticated network attacker could therefore call arbitrary Danswer endpoints, including admin and write operations, with the service account's permissions. Upgrade to @eeacms/volto-chatbot 2.0.4, which is listed as the fixed version.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 8.2 | High | 3.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N | GitHub Advisory Database |
- CISA KEV Not listed.
- EPSS No score.
Timeline
- 31 Oct 2026, 13:32 UTC First seen by agentprime
- 31 Oct 2026, 13:32 UTC Confirmed by OSV