Advisory record · GHSA-w7gh-f2fm-9q8r

PEAR HTTP_Request2 vulnerable to Cross-site Scripting

CVSS 5.4 MediumEPSS 0.0034 · 26th percentile

Published by the GitHub Advisory Database at 17 Apr 2025, 03:30 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
pear/http_request2Packagist<2.7.02.7.0
Identifiers
GHSA-w7gh-f2fm-9q8r · CVE-2025-43717 · PKSA-jrt3-xndd-g4sz
Weakness (CWE)
CWE-79 · CWE-531
Published
17 Apr 2025
Updated
17 Apr 2025

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

PEAR HTTP_Request2 versions before 2.7.0 are vulnerable to cross-site scripting. Several test scripts in its tests directory, including tests/_network/getparameters.php and tests/_network/postparameters.php, echo back any GET or POST parameters without escaping. Upgrade to version 2.7.0 or later.

Written 3 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
5.4 Medium 3.1 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:N CNA (mitre)
  • CISA KEV Not listed.
  • EPSS 0.0034, the 26th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 14:27 UTC First seen by agentprime
  2. 31 Oct 2026, 14:27 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.