Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Froxlor versions before 2.3.6 are vulnerable. An authenticated customer can set the def_language parameter through the API to a path traversal value, causing the panel to include and execute an attacker-controlled PHP file, which can lead to arbitrary code execution as the web server user. Upgrade to Froxlor 2.3.6 or later. The source gives no workaround.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 10.0 | Critical | 3.1 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0052, the 44th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:25 UTC First seen by agentprime
- 31 Oct 2026, 14:25 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-w59f-67xm-rxx7
- OSV: GHSA-w59f-67xm-rxx7
- github.com/froxlor/froxlor/security/advisories/GHSA-w59f-67xm-rxx7
- nvd.nist.gov/vuln/detail/CVE-2026-41228
- github.com/froxlor/froxlor/commit/bc5e6dbaa90e6f3573129da640595e8c770e1d0c
- github.com/froxlor/froxlor
- github.com/froxlor/froxlor/releases/tag/2.3.6