Advisory record · GHSA-w3wc-44p4-m4j7

Auth0 PHP SDK has Insufficient Entropy in Cookie Encryption

CVSS 8.2 HighEPSS 0.0022 · 13th percentile

Published by the GitHub Advisory Database at 1 Apr 2026, 20:29 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
auth0/auth0-phpPackagist>=8.0.0, <8.19.08.19.0
Identifiers
GHSA-w3wc-44p4-m4j7 · CVE-2026-34236 · PKSA-3nzc-cgjr-2gwf
Weakness (CWE)
CWE-331
Published
1 Apr 2026
Updated
1 Apr 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

The auth0/auth0-php package, versions 8.0.0 up to but not including 8.19.0, encrypts cookies with insufficient entropy. An attacker may be able to brute-force the encryption key and forge session cookies. Upgrade to version 8.19.0 or later.

Written 3 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
8.2 High 3.1 CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:N CNA (GitHub_M)
  • CISA KEV Not listed.
  • EPSS 0.0022, the 13th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 14:25 UTC First seen by agentprime
  2. 31 Oct 2026, 14:25 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.