Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Moodle versions from 3.9 before 3.9.14, 3.10 before 3.10.11, 3.11 before 3.11.7, and 4.0 before 4.0.1 are affected. The source gives few details, but a flaw in how failed login attempts are counted can let an attacker bypass the account lockout threshold. Upgrade to 3.9.14, 3.10.11, 3.11.7, or 4.0.1, depending on your branch.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 9.8 | Critical | 3.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H | GitHub Advisory Database |
- CISA KEV Not listed.
- EPSS 0.051, the 92nd percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:30 UTC First seen by agentprime
- 31 Oct 2026, 14:30 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-w37f-pvvx-wcwm
- OSV: GHSA-w37f-pvvx-wcwm
- nvd.nist.gov/vuln/detail/CVE-2022-30600
- github.com/moodle/moodle/commit/59b5858da200f63ecb59a9113af2b99ef1496fe5
- bugzilla.redhat.com/show_bug.cgi?id=2083613
- github.com/moodle/moodle
- lists.fedoraproject.org/archives/list/[email protected]/message/OGF35EN5K2R6X3NTY3XPZSJ3UDASMXI6
- lists.fedoraproject.org/archives/list/[email protected]/message/PIMSIRKCFLIC646K4GMUSZU7THOUVPAJ
- lists.fedoraproject.org/archives/list/[email protected]/message/QCTWSE3JDMSYL7DPCMXMMJEXZSS6VIA5
- moodle.org/mod/forum/discuss.php?d=434582
- git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-73736