Advisory record · GHSA-w2v8-php4-p8hc

Wagtail has permission check bypass when editing a model with per-field restrictions through `wagtail.contrib.settings` or `ModelViewSet`

CVSS 2.7 LowEPSS 0.0048 · 41st percentile

Published by the GitHub Advisory Database at 1 May 2024, 16:35 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
wagtailPyPI>=6.0.0, <6.0.36.0.3
Identifiers
GHSA-w2v8-php4-p8hc · CVE-2024-32882 · PYSEC-2026-2031
Weakness (CWE)
CWE-280 · CWE-281
Published
1 May 2024
Updated
10 Sept 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

Wagtail versions 6.0.0 up to but not including 6.0.3 are vulnerable when a model exposed through wagtail.contrib.settings or ModelViewSet has a FieldPanel permission restriction on one or more fields. A user who has edit permission on the model but not on the restricted field can craft a POST request to change that field's value; ordinary site visitors and users without model edit access cannot exploit it. Upgrade to Wagtail 6.0.3 or 6.1. For ModelViewSet, registering the model as a snippet is a workaround; no workaround is available for wagtail.contrib.settings.

Written 5 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
2.7 Low 3.1 CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:L/A:N CNA (GitHub_M)
  • CISA KEV Not listed.
  • EPSS 0.0048, the 41st percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 14:35 UTC First seen by agentprime
  2. 31 Oct 2026, 14:35 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.