Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
OpenTofu versions before 1.10.7 are vulnerable to denial of service during "tofu init" when it installs modules or providers from attacker-controlled sources. An unauthenticated attacker who controls a TLS certificate chain or a module tar archive can cause excessive memory use, high CPU use, or a crash, but cannot execute code or disclose data. Upgrade to OpenTofu 1.10.7. For older 1.9 and 1.8 releases, which have no fix, review new dependencies before adding them to the configuration.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 3.1 | Low | 3.1 | CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:N/A:L | GitHub Advisory Database |
- CISA KEV Not listed.
- EPSS No score.
Timeline
- 31 Oct 2026, 14:14 UTC First seen by agentprime
- 31 Oct 2026, 14:14 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-w2jf-268q-mrvh
- OSV: GHSA-w2jf-268q-mrvh
- github.com/opentofu/opentofu/security/advisories/GHSA-w2jf-268q-mrvh
- github.com/opentofu/opentofu/issues/3458
- github.com/opentofu/opentofu/issues/3462
- github.com/opentofu/opentofu/issues/3464
- github.com/opentofu/opentofu/issues/3465
- github.com/opentofu/opentofu/pull/3467
- github.com/opentofu/opentofu
- github.com/opentofu/opentofu/releases/tag/v1.10.7
- www.cve.org/CVERecord?id=CVE-2025-58183
- www.cve.org/CVERecord?id=CVE-2025-58185
- www.cve.org/CVERecord?id=CVE-2025-58187
- www.cve.org/CVERecord?id=CVE-2025-58188