Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Metricbeat (Go module github.com/elastic/beats/v7) is vulnerable to denial of service in versions before 8.19.10, from 8.0.0 up to 9.1.10, and from 9.2.0 up to 9.2.4, plus an older pre-release range. An attacker who can send malformed payloads to the Graphite or Zookeeper server metricsets, or supply malformed metric data to the Prometheus helper module, can crash or disrupt Metricbeat. Upgrade to 8.19.10, 9.1.10, 9.2.4, or 7.0.0-alpha2.0.20251217054608-6e42552a23ce or later.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 6.5 | Medium | 3.1 | CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H | CNA (elastic) |
- CISA KEV Not listed.
- EPSS 0.0043, the 37th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:13 UTC First seen by agentprime
- 31 Oct 2026, 14:13 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-w2gr-585j-r428
- OSV: GHSA-w2gr-585j-r428
- nvd.nist.gov/vuln/detail/CVE-2026-0528
- github.com/elastic/beats/commit/0025fbfe668936eb8fa65b838508faf3c3c04387
- github.com/elastic/beats/commit/6e42552a23cec734e7977ebd3eb7fb797ddce456
- github.com/elastic/beats/commit/c7664c91a5a68c2df782bfeffe4fb7f42ff2ad1a
- discuss.elastic.co/t/metricbeat-8-19-10-9-1-10-9-2-4-security-update-esa-2026-01/384519
- github.com/elastic/beats