Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
The github.com/go-jose/go-jose/v4 package before 4.1.5 and github.com/go-jose/go-jose/v3 at or below 3.0.5 are affected. Parsing deeply nested JSON from untrusted input can exhaust the stack and crash the application. Upgrade v4 to 4.1.5; no fixed v3 version is listed, so reject large inputs before parsing.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 6.9 | Medium | 4.0 | CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0029, the 21st percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:11 UTC First seen by agentprime
- 31 Oct 2026, 14:11 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-vvm8-gf78-28g4
- OSV: GHSA-vvm8-gf78-28g4
- github.com/go-jose/go-jose/security/advisories/GHSA-vvm8-gf78-28g4
- nvd.nist.gov/vuln/detail/CVE-2026-116586
- github.com/go-jose/go-jose/pull/290
- github.com/go-jose/go-jose/commit/a31af25836222f4c45d366d6e8f9b1049dd9935a
- github.com/go-jose/go-jose
- github.com/go-jose/go-jose/releases/tag/v4.1.5