Advisory record · GHSA-vvg7-8rmq-92g7

Auth0 WordPress has Improper Audience Validation via Auth0-PHP SDK Dependency

CVSS 6.8 Medium

Published by the GitHub Advisory Database at 17 Dec 2025, 20:57 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
auth0/wordpressPackagist>=5.0.0-BETA0, <5.5.05.5.0
Identifiers
GHSA-vvg7-8rmq-92g7 · PKSA-q26s-yhsm-92t7
Weakness (CWE)
CWE-863 · CWE-1395
Published
17 Dec 2025
Updated
4 Feb 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

Auth0 WordPress plugin (auth0/wordpress) versions 5.0.0-BETA0 through 5.4.x, when built on Auth0-PHP SDK versions 8.0.0 through 8.17.0, fail to properly validate token audience, so applications may accept ID tokens as access tokens. The source does not describe the attacker's required position or the exact impact beyond this. Upgrade the Auth0 WordPress plugin to version 5.5.0 or later.

Written 3 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
6.8 Medium 3.1 CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N GitHub Advisory Database
  • CISA KEV Not listed.
  • EPSS No score.

Timeline

  1. 31 Oct 2026, 14:26 UTC First seen by agentprime
  2. 31 Oct 2026, 14:26 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.