Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
PySpector versions before 0.1.8 have a plugin code validator, PluginSecurity.validate_plugin_code, whose blocklist of dangerous calls can be bypassed. An attacker who can supply a plugin file and get it installed and run can execute arbitrary operating system commands with the privileges of the PySpector process. Upgrade to PySpector 0.1.8, which is the listed fixed version. Avoid installing plugins from untrusted sources, and do not use the --trust flag with them.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 6.9 | Medium | 4.0 | CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:A/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0019, the 8th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 15:01 UTC First seen by agentprime
- 31 Oct 2026, 15:01 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-vp22-38m5-r39r
- OSV: GHSA-vp22-38m5-r39r
- github.com/ParzivalHack/PySpector/security/advisories/GHSA-vp22-38m5-r39r
- nvd.nist.gov/vuln/detail/CVE-2026-41206
- github.com/ParzivalHack/PySpector/commit/3c9547157fc07396f22b26b3484a9a91eba98555
- github.com/ParzivalHack/PySpector/commit/4e279e078c53d760fd321ff9b698d683c65ccb8e
- github.com/ParzivalHack/PySpector