Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
GraphQL-core (PyPI package graphql-core) versions 3.0.0 up to but not including 3.2.12, and 3.3.0a1 up to but not including 3.3.0rc1, are vulnerable. A single small, highly compressible query can make the OverlappingFieldsCanBeMerged validation rule run for minutes on one CPU core, enabling denial of service by unauthenticated remote requests. Upgrade to graphql-core 3.2.12 or 3.3.0rc1, which cap the number of field comparisons per document. Until then, reject oversized documents after decompression before they reach validation.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 7.5 | High | 3.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0060, the 48th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:08 UTC First seen by agentprime
- 31 Oct 2026, 14:08 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-vj8h-fx38-h3vc
- OSV: GHSA-vj8h-fx38-h3vc
- github.com/graphql-python/graphql-core/security/advisories/GHSA-vj8h-fx38-h3vc
- github.com/graphql-python/graphql-core/commit/150e59814d97d12140be005a558c93188ef89198
- github.com/graphql-python/graphql-core/commit/29c2753a7ee30a96a4109e7c6add1a2dae0497d7
- github.com/graphql-python/graphql-core
- github.com/graphql-python/graphql-core/releases/tag/v3.2.12
- github.com/graphql-python/graphql-core/releases/tag/v3.3.0rc1