Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Affected versions of the SpiceDB package github.com/authzed/spicedb from 1.29.3 before 1.49.1 can crash the process through a LookupResources cursor token whose Sections field holds an invalid relationship string, which triggers a panic during parsing. An attacker needs a gRPC connection to the SpiceDB instance plus a valid token, or the ability to pass a cursor token from outside into SpiceDB, and can then take SpiceDB down, reducing its availability. Upgrade to version 1.49.1 or later; you can also stop clients from setting the optional_cursor field in LookupResources calls.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| Not published | None | 4.0 | CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:U | GitHub Advisory Database |
- CISA KEV Not listed.
- EPSS No score.
Timeline
- 31 Oct 2026, 14:14 UTC First seen by agentprime
- 31 Oct 2026, 14:14 UTC Confirmed by OSV