Advisory record · GHSA-vfpx-q664-h93m

Auth0 WordPress Plugin has Insufficient Entropy in Cookie Encryption

CVSS 8.2 High

Published by the GitHub Advisory Database at 3 Apr 2026, 03:43 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
auth0/wordpressPackagist>=5.0.0-BETA0, <5.6.05.6.0
Identifiers
GHSA-vfpx-q664-h93m · PKSA-rbsn-2z23-mspc
Weakness (CWE)
CWE-331
Published
3 Apr 2026
Updated
3 Apr 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

The Auth0 WordPress plugin, versions 5.0.0-BETA0 up to 5.6.0 (exclusive), encrypts cookies with insufficient entropy. An attacker who can use the cookies could brute-force the encryption key and forge session cookies. Upgrade to version 5.6.0 or later.

Written 3 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
8.2 High 3.1 CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:N GitHub Advisory Database
  • CISA KEV Not listed.
  • EPSS No score.

Timeline

  1. 31 Oct 2026, 14:25 UTC First seen by agentprime
  2. 31 Oct 2026, 14:25 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.