Advisory record · GHSA-vfp2-c8pq-v6h6

vLLM from 0.9.2 before 0.24.0 contains a server-side request forgery vulnerability that allows API callers to force outbound connections by embedding a decode address in the X-Request-Id header. At...

CVSS 8.8 HighEPSS 0.0032 · 24th percentile

Published by the GitHub Advisory Database at 25 Oct 2026, 14:16 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
vllmPyPI>=0.9.2, <0.24.00.24.0
Identifiers
GHSA-vfp2-c8pq-v6h6 · CVE-2026-116176 · PYSEC-2026-4351
Weakness (CWE)
CWE-918
Published
25 Oct 2026
Updated
29 Oct 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

vLLM versions from 0.9.2 before 0.24.0 contain a server-side request forgery flaw in which a decode address embedded in the X-Request-Id header can make the P2pNcclConnector prefill worker connect over ZMQ to an attacker-chosen host. An API caller who can send requests to the server could exploit this to leak the NCCL unique_id and KV-cache tensors or to block the worker. Upgrade vllm to version 0.24.0 or later.

Written 31 Oct 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
8.8 High 4.0 CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:L/SC:N/SI:N/SA:N CNA (VulnCheck)
  • CISA KEV Not listed.
  • EPSS 0.0032, the 24th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 25 Oct 2026, 13:20 UTC Confirmed by the CVE List
  2. 25 Oct 2026, 14:16 UTC Confirmed by NVD
  3. 31 Oct 2026, 14:07 UTC First seen by agentprime
  4. 31 Oct 2026, 14:07 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.